
Changes in CabWriter Version 2.0.0 Beta 2-20-2018 
 

Important Note: 

In this release there are a number of changes to Sectioning, Hatching and LayOut tools. You will read 

about them below. But here are some guidelines and rules of use you should be aware of in order to use 

these tools appropriately: 

1. Your model must completely reside in quadrant 1; i.e. positive R, G and B axes. Sections must be 

parallel to the Red/Green plane for plan views, and parallel to either the Blue/Green plane or the 

Blue/Red plane for elevation views.  

2. Do things in the order suggested by the order of the command list in File > CabWriter to LayOut. 

3. Assign Hatches first, and be certain that you have the ones you want so you don’t have to change 

the assignment later. If you make a change later when you have a number of scenes with sections, 

you are likely to have to delete all section cuts (those on Z layers) and recreate them. 

4. Only when you are sure the model is final, i.e. there are likely to be no future changes, should you 

begin creating scenes. At that point you should use Create Sections From Section Planes to create all 

plan and section scenes. Choose the name of all scenes carefully, because those will be the names of 

the Pages and drawing titles in LayOut. You DO NOT want to change those names in LayOut later, 

especially if you have done dimensioning. So when naming a scene be sure it is the name you want 

to see in LayOut. 

5. At this point you want to freeze your design and use the CabWriter Production Documentation 

command to produce the cut lists, CSV files and DXF files you will need. 

6. Use the LayOut Document Setup command to specify the template you will use, its margins, line 

weight and default scale. 

7. Use the Send Scenes to LayOut command to transfer all of your scenes to LayOut; there will be one 

page in layout for each scene in SketchUp. You can use this command multiple times if you add 

scenes after its first use. Each time you use this command it will add any new scenes to pages in 

LayOut, but will not change previously transferred scenes. That must be done in LayOut with the 

update feature. Also, if you delete a scene in SketchUp you need to manually delete its 

corresponding page in LayOut. Always close the LayOut file before using this command again. 

8. Use the Hatch Sections in LayOut to add patterns to the sections in LayOut. CabWriter will create a 

Hatch layer in LayOut where all the section hatching will reside. You can use this command multiple 

times, but before each subsequent use delete the Hatch layer and its contents in LayOut and then 

save and close the file. 

Doing things in this order and following these guide lines will make creating LayOut model files easy. Of 

course you can always make changes at any step along the way, but those changes will result in rework 

and can be quite time consuming. So be sure you model is really ready before proceeding to the next 

step. 



New Functionality 

1. Changed how the Assign Hatches tool works. Before you could use the Assign Hatches tool you 

needed to bring the hatch materials you wished to use into your model. This is no longer necessary. 

CabWriter provides the needed materials and they are loaded into the In Model Materials dialog 

box when the Assign Hatches tool is selected. 

 

The updated Associate Material to Hatch dialog box, which appears when the user chooses the 

Assign Hatches tool, is shown below. 

 

Notice that it is wider; now 600 pixels wide. This was done to allow for long material and hatch 

names. Also notice the OK button has been removed. The Cancel button starts out as Cancel. 

 

When the dialog box first opens CabWriter collects all the Material Types used in the model, and for 

each Material Type, it collects all the Material Names used in the model. Initially the First Material 

Type will be set in the Material Type field, and the first associated Material Name is loaded into the 

Material Name field. CabWriter also collects all the CabWriter Materials in the model and loads 

them into the Hatch Name dropdown, with None being the first valid selection. 

 

The Rotation and Scale drop down fields permit the user to select parameters used by LayOut to 

manage patterns; these parameters will be placed in the Pattern Fill dialog box in LayOut in the 

Rotation and Scale fields. In LayOut, patterns can be rotated and they can be scaled. This is useful in 

matching pattern sizes and orientation to drawing shapes and sizes. These parameters have no 

effect in SketchUp. 

 

All five fields are drop down boxes. The procedure for assigning hatches (SketchUp Materials) to 

each CabWriter Material is as follows: 

a. For the initial Material Type and initial Material Name choose a hatch name from the Hatch 

Name dropdown. You selection will automatically be saved. 



b. Select the next Material Name from the Material Name dropdown. Choose a hatch name 

from the Hatch Name dropdown. Each time you make a selection from the Material Name 

drop down CabWriter will check to see if that combination of Material Type/Material Name 

has been assigned a Hatch Name, and if it has that name will be loaded into the Hatch Name 

field. Otherwise the Hatch Name Field will display None. None is a valid selection for a hatch 

pattern. 

c. Repeat step b until you have assigned a Hatch Name for each Material Name in the Material 

Name dropdown. 

d. Select the next Material Type in the Material Type dropdown. Call this the initial Material 

Type and repeat steps a through c until each Material Type and each of its Material Names 

have been assigned a Hatch Name. At this point the Cancel button will be renamed to Done. 

See the image below. 

 

Each time you make a selection from the Material Type drop down CabWriter will check to 

see if that combination of Material Type/Material Name has been assigned a Hatch Name, 

and if it has that name will be loaded into the Hatch Name field. Otherwise the Hatch Name 

Field will Display None. None is a valid selection for a hatch pattern. 

e. You can click Done at this point, or continue to make changes to any Material Type/Material 

Name combination. When satisfied Click Done. 

 

 

If you click Cancel before Done you will be asked if you are sure you want to Cancel. If you 

answer Yes you will exit the Assign Hatches tool and all of your assignments will be lost. 

 

Once you have assigned all of your materials a hatch pattern and click Done, all of the 

assignments will be saved in the model file. Therefore you can close the file and upon re-

opening the file you will have the same assignments available. 

 



Note, that when you reopen the Associate Material to Hatch dialog box in a model that has 

already assigned hatches to materials, those Hatch Names will appear in the Hatch Name 

field. Further, unless you have added material types or material names in the interim, the 

Cancel button will be named Done, indicating that all the materials have been assigned a 

hatch pattern. You don’t have to click the Done button at this point; you can proceed to 

make changes or just review your assignments. 

 

If you have added either material types or material names since last opening and closing the 

dialog box, the assignments that you previously made will show up in the Hatch Name field. 

The new assigned types or names will have None in the Hatch Name field and the Cancel 

button will still be named Cancel indicating that there are more assignments to be made. 

2. Made a number of changes to the Draw > CabWriter > Create Section From Section Plane to make it 

easy to recreate or redefine a current section. If you are creating a section for the first time you 

proceed as usual, by placing a section plane where you want it using the SketchUp Section Plane 

tool, and then select Draw > CabWriter > Create Section From Section Plane. Note: Since you just 

placed a new section plane, it is the active section cut, and you do not have to select it as you did in 

the past; just proceed directly to the Draw > CabWriter > Create Section From Section Plane 

command. Provide a section view name and color and click OK and the section mask and scene will 

be created. 

 

Now here is the big change. If you make changes to your model that requires a section change, you 

have several options. You can begin by placing a new section plane with the Section Plane tool; or 

you can use the Display Section Planes tool to display the current section planes and you can choose 

one by selecting it with the Select tool. Then choose the Draw > CabWriter > Create Section From 

Section Plane command. Type in the name of the section you wish to change exactly as it currently 

appears in the scene tab (or Scenes dialog box). You will get the following user message. 

 

You have three options. Click Yes will delete the current section mask, create a new one with the 

model changes and place it on the same Z layer the old one was on. Click No and the old section 

mask will not be deleted, a new one reflecting model changes will be placed on the same Z layer and 

will be the active cut. Click cancel to exit without any changes. 

Another option now available is to create a new section, with a new name, but using an existing  



section plane. Simply use the Display Section Planes tool to display currently available section and 

choose one with the Select tool. In the Section View dialog box, which appears following the 

selection of the Draw > CabWriter > Create Section From Section Plane command, provide a new 

(unused) name. 

 

The last change is that when you use the Draw > CabWriter > Create Section From Section Plane 

command the Shaded With Textures rendering option is selected. This is to ensure that the scene 

will display any hatching that the user assigns. 

3. Made some more changes to the Draw > CabWriter > Create Section From Section Plane command. 

The user now has a choice of three modes for creating a section. See the image below. 

 

All – All is the normal mode. The section includes all CabWriter components, including walls, in the 

section cut. All layers that contain a CabWriter component or wall are visible in the created scene. 

 

By Selection – Any selected CabWriter components or wall will be in the section cut. Components or 

walls not selected will be hidden. Selection can be accomplished with the Select tool or any of the 

CabWriter section tools such as the context menu CabWriter > Select Cabinet. Only the layers that 

selected CabWriter components or walls reside on are visible. You can choose a section plane from 

one that currently exists in the model or use the Section Plane tool to create a new one. Whichever 

method is used, you must actually select that section plane with the Select tool. So the order is 

important. To use a currently available section plane follow this procedure: 

 

a. Make your selection of 

components first. 

b. Choose the Display Section Planes 

tool to make all section planes 

visible. 

c. Press and hold the Ctrl key and 

with the Select tool select a 

section plane. This will add that 

plane to the selection. 

d. Choose the Draw > CabWriter > 

Create Section From Section Plane 

command. 

e. Choose the By Selection radio 

button. 

 

To use a new section plane follow this procedure: 

 

a. Us the Section Plane tool to place and located your desired section cut. 

b. Make your component selections. 



c. Press and hold the Ctrl key and with the Select tool select the new section plane. This will 

add that plane to the selection. 

d. Choose the Draw > CabWriter > Create Section From Section Plane command. 

e. Choose the By Selection radio button. 

By Layer – You can choose one or more layers from which to create a section view. All of the CabWriter 

components and walls on those layers will be included in the section cut and only those layers will be 

visible in the created view. Follow this procedure. 

a. Make only the desired layers visible. 

b. Create a new section plane with the Section Plane tool or select a currently available 

plane. 

c. Choose the Draw > CabWriter > Create Section From Section Plane command. 

d. Choose the By Layer radio button. 

 

After the view is created the user may have to choose a standard camera view from the view icons 

or the Camera > Standard Views menu. I hope to rectify this in a future release. 

 

The selections you make in the Section Color dropdown and the radio buttons will be saved and will 

be the default selections the next time the Selection View dialog box is opened. 

4. When a CabWriter project is created, each time the user selects the Assign Hatches tool the pattern 

files in the Plugins\cabwriter\hatch files\ folder are loaded into the In Model Materials library so 

they are available for hatch association with the Assign Hatches tool. There are currently thirteen 

pattern files available, listed below. 

a. Adobe Rammed Earth 

b. Aluminum.skm 

c. Basketweave.skm 

d. Black Dots 1 

e. Brick Common Face 

f. Concrete Masonry Unit 

g. Herringbone 2x1.skm 

h. Honeycomb.skm 

i. Plywood.skm 

j. Rectangles Running 3x1 

k. Steel 

l. Terrazzo.skm 

m. Windmill.skm 

 

5. Added a new File menu command category called CabWriter to LayOut which has two sub-menus: 

a. Assign Hatches 

b. Create Section From Section Plane 

c. LayOut Document Setup 



d. Send Scenes to LayOut 

e. Hatch Section in LayOut 

 

The ordering of theses commands are the order in which they operations should be 

performed. Assign Hatches tool is the same tool as the Assign Hatches tool icon; it is 

included here to provide a visual sequence to follow. Create Section From Section Plane is 

also placed here to show the order and is the same as Draw > CabWriter > Create Section 

From Section Plane. 

 

This new File menu and its sub-menus will only appear if the SketchUp version is 2018 or 

higher. The purpose of these commands is to permit the user to define a LayOut file, using a 

selected template, and send each scene in the SketchUp model to a LayOut page. When 

completed the LayOut file will open. The LayOut file location will be the same folder that the 

SketchUp model resides in, and the LayOut file name will be the same as the SketchUp 

model but with a .layout extension. 

 

Before using these commands the user should open LayOut and create one or more custom 

templates and use the LayOut File > Save as Template command to place them in the users 

template folder; LayOut will automatically place them in the correct folder. Do not change 

their location because CabWriter will expect to find them there. There should be one 

template for each paper size the user intends to use, and for each of portrait or landscape 

orientation desired. LayOut has a lot of base templates the user can begin with, but they 

must be saved in the user’s folder using File > Save as Template. Print out each template for 

measurements you will make shortly. 

 

Once you have saved one or more templates use the File > CabWriter to LayOut > LayOut 

Document Setup command to open the LayOut Document SetUp dialog box shown below. 

 



 

 

Choose a paper size from the Paper Size drop down. Select either Landscape or Portrait 

from the Orientation crop down. Select a template from the Template drop down; in the 

image above I chose NESAW (New England School of Architectural Woodworking, 

nesaw.com ). See the NESAW template on the next page. Using the printout for this 

template measure the margins on each side required to place a scene within the useable 

space. For this NESAW template, which is 24” x 36”, I determined that a 1” left and top 

margin was best. The right required a 7” margin because of the title box and the bottom 

2.5”. I entered these into the Template Margins fields. 

http://www.nesaw.com/


  



After filling in the margins fields the user must select a line weight from the Line Weight drop down box. 

This parameter is placed in two places in the LayOut model file: for each Page in LayOut, in the SketchUp 

Model dialog box Styles tab, it will be written into the Line Weight field; second in the Shape Style dialog 

box it will be placed in the Stroke line width field (this field is not labeled). The default Line Weight in 

CabWriter is 0.40pt. This seems to be a good line weight both visually and for printing. 

Next the user needs to select a Model Scale. CabWriter’s default for this is 1 : 10, meaning 10 units of 

length in the SketchUp model will be drawn in 1 unit of length in the LayOut template paper space. The 

units are unit-less, but a Model Scale of 1 : 10 can be interpreted as 1”(1mm) in LayOut equals 10” 

(10mm) in the SketchUp model. This default Model Scale works pretty well for kitchen models 

transferred to Arch D paper in LayOut. It will be used in each Scene/Page pair for scenes that use 

Camera > Parallel Projection rendering in the SketchUp model. 

When the Assign Hatches, Create Section From Section Plane and LayOut Document Setup 

commands/tools have been used in that order, and all of the scenes the user desires have been created, 

the user is ready to use the Send Scenes to LayOut command. Remember that the Create Section From 

Section Plane tool creates one scene and one section layer and therefore must be used multiple times to 

create all the plan and sections views required. The Send Scenes to LayOut command will create a 

LayOut document with the same name as the SketchUp model and place it in the same folder. Within 

the LayOut model CabWriter will create a page for each scene with the same name as the SketchUp 

scene. The user should not change these names in LayOut; rather make sure the scene names in 

SketchUp are the names you will want in LayOut. CabWriter will place all of the scenes content on a 

LayOut layer called Models for each page. If the file doesn’t have a Models layer CabWriter will create 

one. When it is done it will save and open the file. 

Once the LayOut model file has been created, the user can, and absolutely should at that time, adjust 

the scale of each Page in LayOut to a scale that is optimal for that page. Be sure to do this before using 

the Hatch Sections in LayOut command. An example of one such page can be seen on the next page. The 

model didn’t take quite the entire usable space because of the scale I used for that page; 1 : 2.25. 

However, since this page is not yet dimensioned this is probably a good thing. 

If you add scenes to the SketchUp model after creating a LayOut file you can use the same process to 

update the LayOut file. CabWriter will leave the current scenes untouched and just add the new scenes. 

The user is now ready to use the Hatch Sections in LayOut command. This command will replicate the 

sections in SketchUp on a Hatch layer in LayOut, applying the hatch material with the Rotation and Scale 

parameters applied. Hence the hatches may look different than in the same scene in SketchUp. Prior to 

using this command it is suggested that the LayOut document be closed. It will reopen one the LayOut 

hatching is complete. 



  



6. Added a feature to the Section View 

dialog box, which appears when the 

user selects Draw > CabWriter > 

Create Section From Section Plane. 

When this dialog box opens the Use 

Selected Scene Name? check box is 

unchecked. The Section Name field 

is populated with the suggested 

name of Section – A. If the user 

checks the Use Selected Scene 

Name? check box the Section Name 

field will be populated with the 

name of the current active scene. If 

the check box is unchecked the 

Section Name field will revert to the suggested name of Section – A. 

7. Added one more button to the 

Associate Material to Hatch dialog 

box. The name of the button is 

Save Partial Assignments and 

Close. There are times when the 

user does not want or need to 

assign a hatch material to all 

CabWriter components; e.g. 

Walls. This button permits the 

user to assign one or mare 

materials and save them without 

waiting for the Cancel button to turn to Done. Any material that is not assigned will automatically be 

assign the defaults of None for Hatch Name, 0 for Rotation and 1 for Scale. All other buttons and 

drop downs work as previously described. 

8. Changed what sheet good components are included in DXF reports. In the past only box parts were 

included; e.g. those with prefixes like C2UB6 Back. This meant that parts such as frame and panel 

door panels were not included in a DXF report. Now, and sheet good is included. 



9. Made yet another change to the 

Production Documentation dialog box. 

This change was made to eliminate the 

possibility of double accounting when 

producing CabWriter Production 

Documentation. A number of users like to 

create scenes such as exploded views. This 

generally meant copying cabinets from 

one scene to an exploded view scene, and 

then pulling the parts away from the 

center to show how they are assembled. 

This meant that there were duplicates of 

some parts in the model and hence the 

possibility of double accounting them in 

the cut list or DXF files. 

 

The solution we came up with is both 

simple and useful. To use the CabWriter 

Production Documentation command you 

must first create at least one scene in the 

model; preferably three or more. One 

scene should be dedicated to generating a 

Doors & Drawers report if you plan to 

purchase those from a third party. In the 

model on the next page I have created a 

Purchased Parts scene which includes 

layers Base and Upper Doors, Drawer 

Boxes and Drawer Fronts. No other layers, 

except of course Layer0, are included. 

 

Similarly, I created a Cut List scene 

dedicated to producing a cut list of every part that will be milled and produced in the shop. This 

included layers Base Back Panels, Base and Upper Boxes, Base and Upper End Panels, Base and 

Upper Face Frames, Base Ladder and Crown Molding. Crown molding is not a CabWriter component 

and will not show up on the cut list unless you use Make CabWriter Component on them and assign 

them a custom part prefix; e.g. C10UCP Crown Molding #6. Notice that the doors, drawer fronts and 

drawer boxes do not show up in this scene because they will be purchased from a third party. 

 

Lastly I created a DXF scene with only layers Base and Upper Boxes. This is all I want cut on the CNC 

machine. Now, with these scenes created, I assign them in the Production Documentation dialog 

box using the Door & Drawer Scene, Cut List Scene and DXF Scene drop down boxes. So when 

producing the Doors & Drawers report CabWriter will only include those parts included in the 



Purchased Parts scene; the Cut List will include only the parts in the Cut List scene and the DXF 

report will include only the parts in the Cut List scene. 

 



   



10. Modified the CabWriter toolbar. I re-arranged it and organized it with separators. Also added a new 

tool icon for the “CabWriter Production Reports” command. 

11. Added a message at the beginning of the CabWriter Production Documentation command that let 

the user know that this command can take several minutes, depending on the number of reports 

chosen and the size of the model. It also warns the user to close the Outliner dialog box, which can 

double or triple the compute time of this command. 

Fixes 

1. Fixed a problem when selecting the Make CabWriter Component tool with no entities selected; this 

would result in a Ruby Console error instead of a user message box. 

2. Fixed a problem when using the Draw > CabWriter > Create Section From Section Plane tool on 

components without Extended Entity Info attributes. This would raise a SketchUp error in the Ruby 

Console, but not a user message box indicating the error. Now the user gets a message similar to 

that below. 

 

 
 

The user needs to fix this component and any others that don’t have Extended Entity Info attributes. 

This can be done with either the Extended Entity Info dialog box or the Make CabWriter Component 

tool. 

3. Fixed a problem with the File > CabWriter Production Documentation were an error occurred in you 

did not include either Drawer Fronts, Drawer Boxes or Doors in your selection of reports. 

4. Fixed a problem with the Make CabWriter Component tool. When used on renaming or creating 

door or drawer parts the CutList Bridge attributes were not assigned. 

5. Fixed a bug in the door and drawer reports where slab door quantity was not provided. 

6. Eliminated the tilde (~) symbol from dimensions output in the door and drawer reports. 

7. Permitted the choice of no scene selection in the Production Documentation dialog box if the 

corresponding report was not selected. 

8. Provided a message in the Production Documentation dialog box that requires a type of cut list to be 

selected when requesting a DXF report. 

9. Fixed a problem where the CabWriter Production Documentation tool could try to generate a DXF 

report before a cut list report which would generate errors.  



Changes in CabWriter Version 2.0.0 Beta 1-1-2018 

New Functionality 

1. Added more profiles for cope & stick joinery and provided code that now allows these profiles to be 

used on doors, drawer fronts, end panels and back panels greater than ¾” (19mm). 

a. Outside Edge Profiles 

i. Basic 

ii. Bevel 45 

b. Inside Edge Profiles 

i. Basic 

ii. Bevel 45 

iii. Chamfer 

iv. Inset Radius 

v. Ogee 

vi. Standard 

c. Panel Edge Profiles 

i. Basic 

ii. Cove Raised 

iii. Curve Raised 

iv. Shaker Raised 

v. Standard Raised 

2. Changed the context menu CabWriter > Select Sub-Assembly to remove the work Select in front of 

all the sub-menus. 

 

 
3. De-Stileized CabWriter. CabWriter appeared to many to be a face frame only drawing tool, largely 

because that was its genesis and because the Story Stick is focused primarily on placing stiles. In this 



release we are changing the face frame centric nature of CabWriter. This involves many changes, 

but they can be divided into two major categories: 

a. Distinct Cabinet Design Styles 

There are now three distinct cabinet design styles listed in the Cabinet Style drop down in 

the General section of the Project tab: Face Frame / Hybrid; Frameless Hybrid; and Overlay. 

This is shown below. 

 

 
 

Face Frame / Hybrid is the default set by the factory settings and the Re-Load Factory 

Settings tool. However, before, when Face Frame was chosen, all of the Draw? check boxes 

on the Face Frame tab were locked, except Bottom Rail. Now, when you choose Face Frame, 

all checkboxes are checked but they are all free to be changed, hence the addition of Hybrid 

to the name. 

 

Similarly the Draw? Check boxes are free to be changed in Frameless / Hybrid style, though 

they start out all unchecked, to represent pure frameless. Hence again the Hybrid addition. 

 

The major difference between Face Frame and Frameless is how the cabinet ends are 

treated. End Panels, End Sheets, or End Openings will extend to the front surface of the 

doors and drawers in the Frameless style. 

 

The Overlay style treats End Panels, End Sheets, and End Openings the same as Face Frame; 

i.e. they terminate at a stile with either a miter or butt joint. The doors and drawer fronts in 

the Overlay style sit on, and overlay the face frame by an amounts specified by the 

Door/Drawer Overlay Distance default in the General section of the Project tab. 

 

The last part of the distinct cabinet design styles change is that the Face Frame Door/Drawer 

default in the General section of the Project tab has been removed. 

b. The Story Stick Defines Cabinet Ends, End Treatment and Connections 

Users should now think of the Story Stick as a tool to define the ends of cabinets, 

connections between boxes and how cabinet ends are finished. Here are the choices for 

cabinet ends: 



i. Wall – This is used when cabinets are ending at or 

near a wall. If the Wall Stile Draw? Checkbox is set a 

Wall stile will be drawn with scribe allowance added. 

ii. Panel – This is used when a cabinet will end with a 

frame and panel. If the End Panel Stile Draw? 

Checkbox is set an End Panel Stile is drawn and the 

end panel terminates at the face frame with either a 

miter or butt joint. If the checkbox is not set, the stile 

is not drawn and the end panel will terminate at the 

door/ drawer front. The user should choose a butt 

joint t square the end panel off. 

iii. Sheet – This is used when a cabinet will end with a 

sheet good panel. If the Sheet Stile Draw? Checkbox is 

set a Sheet Stile is drawn and the end panel 

terminates at the face frame with either a miter or 

butt joint. If the checkbox is not set, the stile is not 

drawn and the end panel will terminate at the door/ 

drawer front. The user should choose a butt joint t 

square the end panel off. 

iv. Opening – This is used when a cabinet will end with 

an opening for a dishwasher, sink or other appliance. If the Open Stile Draw? 

Checkbox is set an Opening Stile and filler is drawn and the filler panel terminates at 

the face frame with a butt joint. If the checkbox is not set, the stile is not drawn and 

the filler will terminate at the door/ drawer front. 

v. Connector – This is used when a cabinet will end next to another cabinet. If the 

Connector Stile Draw? Checkbox is set a Connector Stile is drawn. If the checkbox is 

not set, the stile is not drawn. In either case connector holes will be drawn in the 

side if enabled. 

vi. Finish – This is used when a cabinet will end next to another cabinet’s finished panel 

or other finished object; for example a refrigerator cabinet side. If the Finish Stile 

Draw? Checkbox is set a Finish Stile is drawn. If the checkbox is not set, the stile is 

not drawn. In either case connector holes will not be drawn in the side and no scribe 

allowance is provided. Note: Finish use to be called Filler. The names Filler and 

Scribe will now be reserved for a future change that will allow custom parts that the 

designer can add using native SketchUp tools and the Make CabWriter Component 

tool. 

vii. Butt – This is used when a cabinet will end next to a Blind Corner cabinet. If the 

Blind/Butt Corner Stile Draw? Checkbox is set a Butt Corner Stile is drawn. If the 

checkbox is not set, the stile is not drawn. 

viii. Blind – This is used with a Blind Corner cabinet on the end that extends toward the 

wall. If the Blind/Butt Corner Stile Draw? Checkbox is set a Blind Corner Stile is 

drawn. If the checkbox is not set, the stile is not drawn.  



4. Changed the File > CutList Bridge (and CutList Bridge DXF) sub-menu; I deleted all but two sub-menu 

commands: Export to CutList Plus fx and Export to Microsoft Excel or OpenOffice. NOTE: These two 

remaining commands should only be used on NON-CabWriter projects and should NOT be used on 

CabWriter projects. See menu below. 

5. Added a CabWriter command to the File menu. File > CabWriter Production Documentation should 

be used whenever the user wants cut lists, DXF files or door & drawer schedule reports. All 

documentation will be placed in a folder, with a name equal the Project Name in the Project tab, 

and the folder will be placed in the same folder as the applicable .skp file. 

 

 



When menu File > CabWriter Documentation is chosen the user will be presented with the following 

dialog box. 

 

 

 

The Cut List Files Delimiter can be selected to Comma, Tab or Semicolon. Comma is most common in 

countries that use a period for the decimal point. Semicolon is very common in countries that use a 

comma for a decimal point or where there is a lot of commas in use in their reports. Be sure the 

application that you are using to open the spreadsheet .csv and .cwx files are set to the same 

delimiter. 

 

In the Select Desired Reports field the user can select the reports required. The first three selections, 



Drawer Fronts, Drawer Boxes and Doors, will be included in a door_and_drawer_schedule.csv file 

which can be opened in any spread sheet application. This report will look something like the image 

at the top of the next page. All of the dimensions in this report are finished dimensions EXCEPT 

those in the red squares. Those dimensions are the finished height and width but oversized on each 

edge by the amount entered in the “Oversize each side and end by:” field on the Production 

Documentation dialog box. If you leave this field blank or zero, the dimensions in the red squares 

will be finished dimensions. The third line of the report, shown in a red ellipse, shows the value of 

the oversize for reference. 

 

If a door or drawer is a slab it will be listed in either the Slab Doors or Slab Drawer Fronts section. If a 

door or drawer is a frame and panel it will be listed in the Frame & Panel Doors or Frame & Panel 

Drawers sections. In all of these sections the slab prefix or the frame and panel prefix is listed. This is 

the same prefix that shows up in the Sub-Assembly section of the cut list if the Extended Entity Info 

Setup tab is set to Sub-Assembly Attribute in the Sub-Assembly section. Also included in these 

sections is the quantity of slabs or frame and panels required for each prefix (sub-assembly), the 

thickness and in the case of frame and panels the width of the stiles, top rail and bottom rail. 

 

This door_and_drawer_schedule.csv is intended to help shops that purchase drawer boxes, drawer 

fronts and doors from a third party. In the case of Drawer Boxes it will tell the user the number of 

each type slides in pairs i.e. each box requires one pair. It will include the manufactures name and 

part number. This information comes directly from the Drawer Box Depth section of the Drawers 

tab. 

 

The Drawer Boxes section of the door_and_drawer_schedule.csv will list the unique box sizes 

required with a name Drawer Box #, the Width, Height, Depth and the Quantity of each. This report 

will also place in the notes field of each drawer box on the cut list the Drawer Box # for cross 

reference. In CutList Plus fx output, the drawer boxes are in the Other Items tab, and that note 

appears as a little red triangle. As your cursor hovers over the triangle you will see the Drawer Box # 

as shown at the top of the page after the next page. 

  



 

You can choose a Spreadsheet Compatible Cut List and/or DXF by Material Name & Thickness by 

checking the appropriate checkbox. CutList Plus fx has three radio buttons and you can select only 

one at a time. CutList Plus fx provides only the usual cut list. CutList Plus fx provides a folder of 

individual CabWriter SketchUp component .dxf files which will be used by CutList Plus fx to output 

optimized .dxf sheet files. If you do not want a CutList Plus fx file simply choose No CutList Plus fx 

Report. 

 

When you click the OK button CabWriter will begin report generation. The dialog box will remain 

open until you get a message that the reports are complete and it will inform the user where to find 

them. When you click OK both dialog boxes will close.   



 

 

6. Changed what gets generated for DXF files. In older revisions any component with a Material Type: 

Sheet Good would be included in a DXF file. This meant that panels in doors, drawers, end panels 

and back panels would be included in the DXF file. In this revision we have limited the DXF 

generation to only Box components e.g. C10UB1 Bottom. This means that only carcass parts are 

included in DXF generation. This was done because panel plywood, which is typically ¼” (6mm) 

thick, is generally not cut on CNC machines. We may revisit this decision later with more user input. 

7.  

Fixes 

1. It appears that when saving a SketchUp 2018 file as a SketchUp 2017 file, there is a problem with 

the DefinitionList.load method (and perhaps other issues as well). Implemented a work around for 

this situation. 

2. Fixed a bug where the Save CabWriter Defaults tool was not erasing unregistered defaults before 

saving defaults to a file. 



3. Fixed a problem where old models with Extended Entity Information attributes written prior to the 

revision that included Resize Thickness By would cause errors when opened and examined in 

current CutList Bridge versions. 

4. Fixed a problem where when Solid top was chosen for base cabinets, Stretcher holes were drilled, 

not solid top holes. 

5. Fixed a problem where when using an inset bottom value, the bottom drawer box did not move up 

accordingly. The hardware holes did, but not the drawer box. 

6. Fixed a problem where when manually adding a drawer to a divided cabinet with a raised bottom 

the hardware holes and the drawer box did not move up accordingly. 

7. The context menu CabWriter > Set CabWriter Protection did not set the attribute to the correct 

value even though it showed as protected in the Extended Entity Info dialog box. Hence, the 

component wasn’t protected when a Re-Draw tool was used to re-draw a cabinet. 

8. Fixed a problem with drawing corner cabinets with non-end panel or sheets when there was only 

the corner box in the cabinet. Multiple box configurations had no problem. 

9. Fixed a problem where corner cabinet End Sheet panels extended to the face frame like they would 

for frameless. 

10. Fixed a problem with using the Insert a Door tool in an upper cabinet Divided Upper. 

  



Changes in CabWriter Version 2.0.0 Beta 12-8-2017 

New Functionality 

1. The Insert a Door, Insert a Drawer and Create a Back Panel now give the user the option of using the 

cabinet’s stored defaults or the current CabWriter Settings defaults. In the unlikely example below, 

the cabinet was constructed a frameless cabinet with End Sheet end panels. The CabWriter Settings 

were modified to use cope & stick back panels and then the back panel was added using those 

settings, not the cabinet’s stored settings. 

 

 

2. When using the Create a Back Panel tool the Back Panel dialog box input field is now case 

insensitive. See legitimate input in image below. 

 

 

 



3. Added a new default on the Carcass tab at the bottom of the Toe Kick section called ‘Draw Toe Kick 

Frame?’. The options are Yes or No. Yes means that the entire ladder base is drawn. No means that 

the stretchers, ribs, and ties are not drawn leaving only the applied trim faces. See the images 

below. 

 

4. Combo Drawers drawn without a mid-stile now have one Drawer Support between them as 

opposed to a Left Drawer Support and Right Drawer Support. This is true for all base cabinet types 

that permit Combo Drawers. If the mid-stile is drawn then there is both a Left Drawer Support and 

Right Drawer Support. Thickness of the single draw support is the same as the box sides. See the 

Base Cabinets tab on the next page. 

  

 

 



  

Fixes 

1. Fixed a problem where when checking thickness, tongue length and tongue width in cope & stick 

creation, the comparison of dimensions could fail due to floating point inaccuracies. 

2. Fixed a problem in SketchUp 2018 that did not permit the drawing of combo drawer fronts. 

3. Fixed numerous problems created by SketchUp 2018. The explode method returns an array of 

entities. Those entities in 2018 can now include class AttributeDictionaries. 

4. Fixed a problem when drawing a multi-box cabinet with a Lazy Susan or Diagonal Corner box, and 

depending on the direction it was drawn, the front applied face of the ladder base was drawn short 

and with a butt end instead of a miter end. 

5. Fixed a problem where the ladder base ties could be drawn too long by 1” in certain multi-box 

cabinet configurations involving corner boxes. 

6. Removed a redundant and non-functional default from the CabWriter Settings dialog box Face 

Frame tab. Blind Corner Mid Stile is not needed; its functionality is provided by Drawer Mid Stile. 

7. CabWriter allows users to save and open defaults to a file, which is very powerful. These files can be 

shared by simply emailing them to someone or receiving them in the email. There are two potential 

and serious problems with this: first those files can be corrupted since they are merely text files.; 

second they can become obsolete if they were generated on an older version of CabWriter and 



defaults were added, deleted or names changed since. So CabWriter now has a registry of valid 

defaults. This registry is created when a user opens a CabWriter project with the Create Project tool 

or uses the Re-Load Factory Settings tool. When a file is saved it checks for illegal default names and 

blank defaults. A message informs the user to check for and correct blanks in the CabWriter Settings 

tabs. When a file is opened and a blank is read in it will also display in the CabWriter Settings tabs. 

 

In future releases we will add more checks to these files to help assure that they don’t create 

problems and frustration for the user. However, the user should always visually check the CabWriter 

Settings tabs to be sure there are no missing or incorrect defaults. 

  



Changes in CabWriter Version 2.0.0 Beta 11-27-2017 

New Functionality 

1. Completed the frameless end panel inclusion; i.e. End Sheet(s), End Panels(s) and End Opening(s) 

are now drawn whether or not their end stiles are drawn. If their end stiles are not drawn the front 

edge of the end sheet, end panel or end opening will extend to the face plane for the door and 

drawer fronts. See example of frameless below. 

 

 

Note: When an End Opening is created in a cabinet with End Opening Stile(s) drawn the material 

type and name is the same as the Carcass. When an End Opening is created in a cabinet with End 

Opening Stile(s) NOT drawn the material type and name is the same as the End Panel. 

 

2. When creating a CabWriter project with the Create Project tool, a project name is assigned and will 

appear in the Project Name field of the Project tab. This name can be changed at any time after 

creating a CabWriter project; simply change it in the Project Name field. 



3. The menu Extensions > CabWriter > View License and Check for Updates now includes a Licensed 

Version (formerly just Version)field and an Installed Version field. Notice in the image below that the 

Licensed Version is 1.0.0, but the user has installed a beta test version that is newer than the 

Licensed Version. The message below no longer tells the user if the installed version is up to date or 

there is a newer on available. Rather it simply informs the user of the latest available version. 

 

4. Added two new defaults, one each to the Base Cabinets and Upper Cabinets tabs called Back Corner. 

They are dropdown options with the choices Angled and Squared. These defaults determine 

whether the back corner is constructed at a 45 degree angle or square. 

When Squared is selected for the Back Corner the angled Shelf Support is not drawn and the Shelf 

Support shelf holes are consequently not drawn. In their place shelf holes are drawn in the Left and 

Right Back. See examples below. 

 

  



 

 

Note the shelf hole arrangement and the shelf design 

and placement. The L-shaped shelves are drawn by 

CabWriter. The straight shelves, shown right,  were 

simply L-shaped shelves modified in Component Edit 

mode and one of them rotated. The Diagonal Corner 

cabinet (box) is now also available with a square corner. 

Note in these images that CabWriter provides two 

columns of shelf holes in the backs of the cabinet that 

match the shelf holes in the box sides. This is so you can 

have standard L-shaped or straight shelves (image on 

right).  

 

 

 

 



5.  

 

Fixes 

1. Fixed a problem with diagonal corner cabinet. If the Cabinet Style was Frameless and the End Stiles 

were drawn, the door did not position correctly. 

2. Fixed the Door/Drawer Panel Profile raised.skp file, which was cause an error because it contained a 

construction line. 

3. Fixed a problem with Diagonal Corner and Lazy Susan cabinet where the End Opening Fillers were 

not drawn correctly. 

4. Fixed a problem with using Make CabWriter Component to add a Mid Stile to a Face Frame, which 

resulted in a SketchUp error message. The CutList Bridge defaults for Doors and Drawers were not 

loaded. 

5. Fixed the Make CabWriter Component dialog box so that the Description and Instance Name input 

fields now permits pasting into them. 

6. Fixed a problem where, when bottom trim is drawn, on a Lazy Susan cabinet the trim was not placed 

correctly. 

  



Changes in CabWriter Version 2.0.0 Beta 11-7-2017 

New Functionality 

1. Added and changed some defaults on the Carcass tab of CabWriter Settings in the General, Back and 

Joinery sections. The General section is new and has one default called Top/Bottom/Stretcher 

Recess. This default is implemented and works as described in 2 below. The Back and Joinery 

sections appear in the Carcass tab but are not yet implemented. These defaults will become 

important and active when we implement dado, rabbet and packet joinery. 

 

 
 

2. The default called Top/Bottom/Stretcher Recess in the General section of the Carcass tab permits 

the recessing of the top, bottom, top stretchers, mid stretchers and any fixed shelves. The default is 

0”. 

 

3. Renamed the Re-Name Component tool to Make CabWriter Component, changed its icon from  

to  (which I don’t like but will change again later) and also changed its functionality. 

In the past, in order to add a custom component to a CabWriter cabinet you first had to model the 

component in primitives using native SketchUp tools, select all the primitives and then use 



SketchUp’s Make Component  tool to make a SketchUp component. Next you used the Re-Name 

Component  tool to turn the SketchUp component into a CabWriter Component. 

 

I have eliminated one step in this process. To add a custom component to a CabWriter cabinet you 

first model the component in primitives using native SketchUp tools, select all the primitives and 

then use the Make CabWriter Component  tool to make a CabWriter Component. This allows 

you to go directly from selected primitives to a CabWriter Component. 

 

You can still select a component and use the Make CabWriter Component  tool to turn a 

SketchUp component into a CabWriter component, or select a CabWriter component and use the 

Make CabWriter Component  tool to rename or change attributes of the component. However, 

the restrictions are that the selection you pass to the Make CabWriter Component tool must either 

be all primitives or one component, and that component’s definition name must be unique (not 

currently in the model’s definition list). Primitives plus anything else or more than one component 

will result in an error message. 

If the user selection is primitives when using the Make CabWriter Component  tool the Make 

CabWriter Component dialog box will look similar to the following: 

 

 

However, if the user’s selection is a CabWriter component prior to selecting Make CabWriter 

Component tool it will look similar to this: 

 



 

Lastly, if the user’s selection is a SketchUp component (non-CabWriter component) prior to selecting 

the Make CabWriter Component tool it will look similar to this: 

 

 

In all cases the component can be changed to a CabWriter component or a CabWriter component 

renamed. This change was made to streamline the creating of a CabWriter component. There will be 

future changes that will further enhance and streamline the process. 



 

In addition to the look and name change of this tool, a lot of functionality has changed. There are 

three sections to this dialog box. The first section, Current Component Instance Names, simply tells 

the user what the current definition name and instance name are. These fields will not change until 

a successful execution of this tool is completed. Note, for this reason they are grayed out and 

cannot be changed. 

 

The second section, Changes to Component Instance Names & Protection, is where the user will 

make all the changes desired before execution the tool with the OK button. Inside this section some 

fields are labeled in blue italics, one in red italics and the rest are normal black. The blue italics fields 

contain test that will be assembled into a component definition name and displayed in the third 

section in the field called Definition Name. This will happen in real time so that you will see the 

changes as you make them. The red italics label, Sub-Type, is a selection from a drop down list that 

will change as a function of the choice made in the blue italics Component Type drop down. The 

Sub-Type field is not part of the definition name, but rather a classification of a Component Type, 

which is used only to determine the appropriate information to write in the component’s CutList 

Bridge attributes. 

 

Starting at the top of the second section the Cabinet Number field is where the user supplies the 

cabinet number that this new CabWriter component will be assigned. It must be a valid cabinet 

number and that cabinet must currently exist in the model. The user can type the number into the 

field without regard to capitalization; CabWriter will correct for capitalization. But the cabinet 

number must start with the letter C followed by a non-zero integer and end in either U or L. 

 

Next is Component Type. The user must choose a component type from the drop down; blank is not 

a component type. If the Component Type contains the # symbol, the user must then input a non-

zero integer into the unlabeled field next to Component Type. If the selected Component Type does 

not contain a # symbol the unlabeled field will be grayed out. 

 

Next is the Sub-Type field. This field will change each time a Component Type selection is made. The 

user can select blank or any item on the list. If blank is chosen the new component will have CutList 

Bridge attributes initialized to a Milled Part(s) with blank fields except for the correctly assigned Sub-

Assembly and CabWriter Protection. If an item other than blank is chosen the component will have 

correctly assigned attributes based on the current CabWriter defaults, Sub-Assembly and CabWriter 

Protection. 

 

The next field, Description, is where the user supplies the description part of the definition name. 

The description part is the part that comes after the cabinet number and component type. The user 

does not supply the space between the cabinet number/component type and the description; 

CabWriter automatically inserts that. 

The Instance Name field is where the user supplies the new component’s instance name. 

 



To provide CabWriter protection for this new component the user chooses Yes from the Set 

CabWriter Protection? Drop down; or No if no CabWriter protection is requested. 

 

Lastly, the third section, New CabWriter Component Instance Names & Protection, show the 

compiled results from changes made in the Changes to Component Instance Names & Protection 

section. This is what will be written to the new component along with the appropriate CutList Bridge 

attributes when the user clicks on the OK button. The user should carefully inspect this before doing 

so. In addition, once the operation is complete it would be wise for the user to select the new part 

and examine its attributes with the Extended Entity Info dialog box. 

 

Choosing the Cancel button will return the selection to its original state. 

 

NOTE: The Make CabWriter Component cannot be used to change the Instance Name of a normal or 

CabWriter component. Use the Entity Info dialog box to change an Instance Name. 

4. Changed the name of the dialog box opened by the View License and Check for Updates command 

in the Extensions > CabWriter menu. Changed it from Active CabWriter License to View License and 

Check for Updates. 

5. A major functionality addition is the ability to include cope & stick door, drawer, end panel and back 

panel styles. This functionality is only available to users with SketchUp Pro licenses, and at the 

moment only three coped styles are available. We will add many more by the time Version 2.0.0 is 

released. 



 

 

In the above image notice that the Base and Upper Doors Style sections have changed significantly; 

there are now five defaults in each section. Here is there meaning: 

 Door Face Style – Drop down options are: 

 Frame and Panel – door fronts will be constructed as frame and panel unless a door is 

too narrow or too short in which case they will be drawn as a slab. 

 Slab – Doors will be constructed as a Slab. 

 Frame & Panel Style – Drop down options are: 

 Basic Frame and Panel – door fronts will be constructed as a basic frame and panel. 

 Profile Cope & Stick – door fronts will be constructed by cope & stick profiles defined by 

the next three defaults. 

 Frame Outside Edge Profile – Typically a router bit profile used to cut the outside edge of 

the frame. Drop down options at the moment are: 

 Basic – this is a straight edge profile. 

 Bevel 45 – This is an edge profile with a 45 degree chamfer on the front edge. 

 Frame Inside Edge Profile – Typically a router bit profile used to cut the inside edge of the 

frame. Drop down options at the moment are: 



 Basic – this is a straight edge profile. 

 Bevel 45 – This is an edge profile with a 45 degree chamfer on the front edge. 

 Ogee – This is an edge profile with an ogee curve on the front edge. 

 Panel Edge Profile - Typically a router or shaper bit profile used to cut the outside perimeter 

of the panel. Drop down options at the moment are: 

 Basic – this is a straight edge profile. 

 Raised - This is an edge profile with a shallow chamfer and a raised panel. 

 Curved Raised - This is an edge profile with a shallow Bezier curve and a raised panel. 

 

You will not find these five defaults on the Drawers or Panels tabs. It is assumed that drawer fronts, if 

they are not to be Frame and Panel will be a Slab construction. If drawers are to be a Frame and Panel 

construction, they will use the same styles as the doors specified by the Doors tab. Hence on the 

Drawers tab for Drawer Face Style the only drop down options are: Frame and Panel with edge styles 

defined on the Doors tab; and Slab. 

 

In a similar rationale, it is assumed that End Panels and Back Panels will use a similar frame and panel 

style to the doors defined by the Doors tab or a basic frame and panel. Hence the End Panel Style and 

Back Panel Style drop downs only have two options: Same as Door; and Basic Frame and Panel. If you 

want a Slab constructed End Panel, you can choose that by specifying an End Sheet stile at the end of 

the cabinet. At the moment, if you want a Slab constructed back panel you can draw the component 

with native SketchUp tools and then use the Make CabWriter Component tool. 

Here are two examples of cope and stick finishes. 

  



  



 

 



 

6. Changed the default value for Draw Alignment Slot on bot Base and Upper Cabinet tabs to No. 

7. CabWriter now draws End Sheet(s) when Sheet Stile Draw? Checkbox is unchecked; i.e. End Sheet(s) 

are drawn whether the Sheet Stile is checked or unchecked. If Sheet Stile Draw? Is unchecked the 

End Sheet will extend to the same plane as the door/drawer fronts front plane. This change only 

affects Sheet Stiles. In the next beta release it will work the same way for End Panel Stiles and 

Opening Stiles. This change is meant to benefit frameless designs. 



 

 

 

 

 

Fixes 

1. Fixed a problem where the user could not use any of the CutList Bridge File commands on a non-

CabWriter project. 

2. Fixed a problem with the Create a Back Panel tool. Back panels with larger than two panels resulted 

in the last panel being a width stretching from the beginning of the second panel to the end of the 

last panel. The user couldn’t visually see this on the basic panel type unless they looked at its 

dimensions or move it out of the frame and panel assembly. 


